CIC Solutions Forums
Certified Independent Consultant Solutions Forums for
LexisNexis® Practice Management Products
Time Matters - PCLaw - Billing Matters - Browser Edition - HotDocs

TM10, Crystal Enterprise 10 connectivity issue

rated by 0 users
This post has 3 Replies | 2 Followers

Top 500 Contributor
Posts 4
dchenkin Posted: Tue, Dec 22 2009 9:53 AM

I have, what appears to be, a unique issue, that I would like to share with the forum in hopes of finding a solution prior to calling TM support.

 

This past weekend we upgraded to TME 10.0 w/SP1. The server is Windows 2003 with 2003 Small Business Server. The clients are all Win XP with either SP2 or SP3. Since, at least TM4 we have been using Crystal Reports (CR), with the datatxt ODBC driver, and when we upgraded to Enterprise we used Crystal Enterprise (CE) to distribute the reports so staff members can run their own reports.

 

For those who are unfamiliar, CE resides on the server and reports written in CR are then added to CE, which is accessible over the local network. CE connects to the SQL database when a report is run and produces the report’s output. It is normally simple matter to accomplish this. On the client machine, where CR is resident, a user DSN is added to connect to the TM database. I also set up a user and system DSN on the server in order for CE to connect to the data. I use NT authentication to login to the data. (In the spirit of full disclosure, I don’t remember if I need both the user and system, but it works and does not appear to create any issues, so out of force of habit...). Like I say, I’ve been doing this since TM4 and CR 7.5, I am now using CR and CE 10.

 

Back in June we upgraded from TM8 to TM9, made the usual ODBC connections and, other than the trauma of updating all my reports to see the new SQL data, all went well. Until this time.

 

Now, after I have updated the report on my client to use TM10 and “upload” it to CE, when the report is run in CE it asks for login and password to connect to TM10. I enter “sa” in the login and leave the password blank, but the report won’t run. Yet, when I run the same report on my client from CR it connects to the new data with no problem, and without asking for login info.. So what do I do now?

 

I tried changing the DSN to SQL authentication, changed the login to “sa” and I have no issue connecting to the database or running report locally. I would then upload the report to CE and still I am asked for login info, sa w/no password does not work. (At one point during the trial and error of trying to solve this problem, when I ran a report locally on my client in CR I was asked for login info. Putting sa in the user name and no password was all I needed to run the report. It never happened again and I am unsure of the conditions as to why it happened that one time.) In CE you can set the report to either connect to the database using the inherited information in the report itself, or create a custom login. I always use the inherited login info. I tried creating a custom login using various combinations of logins and passwords; sa, sa; lntmuser, sa; lntmuser, no pw; sa, no password; and at the suggestion of my CIC sa and my TM10 key. Nothing works.

 

I am fresh out of ideas, save for reinstalling CE (in hopes of some miracle). Any suggestions would be greatly appreciated. (Sorry for the long post but I wanted to give as detailed a picture as possible). Thanks in advance.

David Chenkin Paralegal Marshall & Marshall Jericho, NY
Top 10 Contributor
Posts 1,280
.CIC
BM CIC
BMP CIC
PCL CIC
TM CIC

There have been changes to the database access in version 10. I am not sure if this affects you but Steve Stockstill blogged about it here : http://www.practicebetter.com/index.php?option=com_content&view=article&id=58:faster-step6&catid=1:inhouseblog&Itemid=2 

Matt

Matt Stone, LLB
Premier CIC - Forum Administrator
7SecondSystem.com
The 7 Second Blog

LexisNexis Platinum Achievement Circle 2009 Top Sales Producer – Time Matters

Top 500 Contributor
Posts 4
dchenkin replied on Tue, Dec 22 2009 5:01 PM

Hi Matt

I took a quick look at Steve's blog. Sounds like this may be the key to my issue. I am going to forward this link to my CIC/network advisor. I'll let you know how it turns out.

Thanks.

David Chenkin Paralegal Marshall & Marshall Jericho, NY
Top 500 Contributor
Posts 4

Just wanted to let you know that I spoke with Steve Stockstill and he found the issue, Because of the secret password associated with the lntmuser account, when I made the connection in Crystal Reports to the TM database, I needed to select the option to trust this connection. Since it was never an issue in the past it never occurred to me this time.

Thanks for turning me on to Steve.

David

David Chenkin Paralegal Marshall & Marshall Jericho, NY
Page 1 of 1 (4 items) | RSS